Jump to content
HWBOT Community Forums

Gigabyte Z97X-SOC Force - Questions , problems

Recommended Posts

  • 4 months later...

Been having a few problems and wondering if anyone can provide help??


Tried X04 bios and had a bit of a play, nothing major and switched on today and constant bsod, returned to default/clr cmos and stlll bsod, only way to get to windows was to select "load defaults and boot"


Flashed back to F6 and still had bsods :( managed to get it working and re installed win7 and 8(2xSSD) all seemed to go well but there back, bsod code f4 which i beleive points to a drive but they both cant be bad and i also get memory management, tried sticks at xmp and defaults (ram is corsair dom plats 2800, also does it with my ripjaws)


Something is not right somewhere and i'm almost certain its the board (hardware) at fault, have also tried both bios's

Link to comment
Share on other sites

  • 3 weeks later...

Thanks for the reply dinos, most of the above problems seem to be ok now, the issue is now pointing at the Lan driver, giving random bsods but mainly when pc is idle or downloading, have found a driver with none of the bloatware and that does it too. Not had much time lately to test thoroughly but hopefully get to the bottom of things ;)

Link to comment
Share on other sites

  • 8 months later...

A couple of questions here, about the latest official bios (F8).


Wanted to check out a Broadwell cpu (i5-5675C).

So i flashed F8 over my X08 on bios 1 chip.


I honestly dont recall any other , flashing procedure taking place at that moment.


But , my bios 2 chip , with X04 version "vanished"

Became F8 version also.


Is that something that suppose to happen or something went wrong here ?

Does F8 Version flashes the backup bios chip at the same time ?


Now , i cant revert back to the X series bioses.

Tried Qflash , Efiflash , @bios ... nothing.


Is there any kind of extra command line (/switches) to be used ?





Now regarding the F8 bios performance on Broadwell cpu's.


Any special treatment-settings needed ?

I had really bad , XTU scores with it.

Really Bad.

Link to comment
Share on other sites

I believe it has to do with the single/dual BIOS switches.


There's definitely a way to flash it back but I think it has to be done via DOS or something like that...


@sofos1990 @dinos22


The efiflash is dos based , but no luck with it.

I tried it.

Perhaps it needs some kind of commands to bypass safety protection.

It needs to force flash.



Take a look here, Ihad similar problem and this was only way to solve it


Thanks i'll give it a try.

The procedure is though dos-usb or within windows ?

Cause i extracted 2 files , one named 32bit and the other 64bit.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...