Jump to content
HWBOT Community Forums
_mat_

GPUPI - SuperPI on the GPU

Recommended Posts

As I mentioned, the downlock happens right I open GPUPI, Also right I close the benchmark, clocks are back. Its 1000% related to GPUPI.

Share this post


Link to post
Share on other sites

As I said, GPUPI has no access to clock speeds, let alone manipulate them. But there is of course always the possibility that the OpenCL or CUDA driver of the card is involved in this and enables another speed step, that is not set up correctly.

 

Please post a screenshot of Afterburner showing the problem and a comparison to another windowed 3d application like Furmark. I am sure we can get to the root of this problem.

Share this post


Link to post
Share on other sites

Ok so just FYI.

 

1st spike = just turning on and of GPUPI (ran at 405MHz)

2nd spike = 1B HWB run (ran at 405MHz)

3rd spike = again turn and off GPUPI

 

then one Furmark run which ran at 1442MHz.

 

I also made a short video

 

Edited by Elkim

Share this post


Link to post
Share on other sites

When i do faster than 1m 02s 507ms the result is invalid, not matter what i use (2.1, 2.1.1, 2.1.2, 2.2). Using 2 different OS (Windows 7 x64 & Windows 10 x64). FYI i use AMD APP SDK 3.0, AMD Crimson Software 15.11. Maybe i do something wrong or any info? Thanks before ;)

Share this post


Link to post
Share on other sites

Invalid result means your hardware is not stable. Even the slightest miscalculation in the first 27 decimals in just one of the billions of partial calculations can output the wrong result. Sometimes I wonder that it even works so well with overclocked cards. :)

Share this post


Link to post
Share on other sites

I would like to run GPUPI 2.2 on CPU, but after the step "Compiling OpenCL kernels" I get the message "Error: Could not create series term kernel 0!" It's the same with the 32 and 64 Bit exe. (Runs fine on GPU though.) Is anybody familar with this issue?

 

System: Win 10 Pro 64 Bit, Core i7-6700K, Asus Maximus VIII Extreme (1701), Geforce GT 650 (359.06)

HPET is enabled, GPUPI uses Intel OpenCL 2.0

Share this post


Link to post
Share on other sites

What's your Intel OpenCL driver version? Any special batch or reduction sizes or is everything at default (20M, 256)? I currently can not reproduce the error.

Share this post


Link to post
Share on other sites

Well, I guess it's complicated or I'm just really out of it. :)

 

When I was trying today to install the Intel OpenCL runtime v16.1 x64 at first I got a message that it's not possible to install it, if there's an Intel graphics driver installed. Ok, so I just removed the graphics driver as I'm not using the IGP at the moment anyway.

 

Then at next I got the "a higher version of the OpenCL runtime for Intel Core and Xeon Processors is already installed" message. So as suggested in the GPUPI guide I deleted the OpenCL key including all subkeys in the registry at path HKEY_LOCAL_MACHINE\SOFTWARE\Intel\OpenCL. However the OpenCL runtime installer still complained that a higher OpenCL runtime version is already installed. So I removed the whole OpenCL folder from C:\Programs (x86)\Common Files\Intel\, too. As you can imagine that had no effect as well. (I made backups of the registry key and the folder.)

 

So at the moment GPUPI doesn't recognize any OpenCL CPU driver and the most recent OpenCL runtime installer claims there's a higher OpenCL runtime already installed. :banana:

 

When I tried to run GPUPI yesterday different batch/reduction sizes made no difference. Apparently I have/had OpenCL 2.0 driver 5.2.0.10094 installed.

Share this post


Link to post
Share on other sites
What's your Intel OpenCL driver version? Any special batch or reduction sizes or is everything at default (20M, 256)? I currently can not reproduce the error.

 

Hey I have been asking around but forgot I should try and ask you. Do you have any idea why a 1B result would be so inefficient using a i3 6100k with newest amd sdk app on windows 7 64 bit.

 

It's so weird my score is like 2 minutes slower than other people with same cpu speed. I know I havent given much info but was just hoping you have heard of this or know why. I seem to be the only person with the trouble.

 

I tried different m8e bios's and a couple of different fresh windows 7 installs, also happened on win 10.

 

I'm so frustrated, I want to give up

Share this post


Link to post
Share on other sites

Post the score please, I'll have a look.

 

Btw, normally you should not use the Intel OpenCL drivers. Use the AMD OpenCL drivers, they are much faster on Intel CPUs as well. If you don't know how to install it, please take a look at the GPUPI international support thread: https://www.overclockers.at/news/gpupi-international-support-thread

There is a FAQ section that has a link to the AMD APP SDK, if you don't have an AMD graphics card.

Share this post


Link to post
Share on other sites
Post the score please, I'll have a look.

 

Btw, normally you should not use the Intel OpenCL drivers. Use the AMD OpenCL drivers, they are much faster on Intel CPUs as well. If you don't know how to install it, please take a look at the GPUPI international support thread: https://www.overclockers.at/news/gpupi-international-support-thread

There is a FAQ section that has a link to the AMD APP SDK, if you don't have an AMD graphics card.

 

 

thanks so much for your help. Thats what I did. I used the newest amd app sdk and installed the amd open cl drivers, I didnt even install the intel ones. Especially with the non k processors the amd version is a must.

 

But if you look at my score its way off. The person right next to me in the rankings has same score at 5.2ghz and I am at almost 6ghz, it's like I am missing something so major but cant figure it out.

 

Strong Island`s GPUPI for CPU - 1B score: 10min 4sec 225ms with a Core i3 6100

Share this post


Link to post
Share on other sites

Your reduction time is completely off, that's the second time listed in the statistics. Others have about 10 seconds, maybe 15, yours is 87 seconds.

 

So check the memory for faulty reads and writes, maybe it's overclocked too high.

Share this post


Link to post
Share on other sites
Your reduction time is completely off, that's the second time listed in the statistics. Others have about 10 seconds, maybe 15, yours is 87 seconds.

 

So check the memory for faulty reads and writes, maybe it's overclocked too high.

 

 

wow so that's over a minute right there which would make my score a lot more normal. I thought I tried with stock memory but maybe not. I'm so excited, going to retry tonight. Thanks so much for your help. I really hope it's the memory.

Share this post


Link to post
Share on other sites
thanks so much for your help. Thats what I did. I used the newest amd app sdk and installed the amd open cl drivers, I didnt even install the intel ones. Especially with the non k processors the amd version is a must.

 

But if you look at my score its way off. The person right next to me in the rankings has same score at 5.2ghz and I am at almost 6ghz, it's like I am missing something so major but cant figure it out.

 

Strong Island`s GPUPI for CPU - 1B score: 10min 4sec 225ms with a Core i3 6100

 

If you can try the amd 1.2 OpenCL drivers because for CPU's it's faster plus do a quick run first because it seems to be fastest on the second run after opening

 

Edit: If you can use amd catalyst 14.2 because it's faster than SDK

Edited by newlife

Share this post


Link to post
Share on other sites
Your reduction time is completely off, that's the second time listed in the statistics. Others have about 10 seconds, maybe 15, yours is 87 seconds.

 

So check the memory for faulty reads and writes, maybe it's overclocked too high.

 

 

its really wierd but i still cant figure it out. i did fresh install and switched to 4gb sticks instead of 8gb. turned memory to almost stock. i was benching i3 6100 at 6.4ghz and when i use 4m 512 reduction i get like 25sec after first batch compared to others who have 18sec. so i tried 1m 64 reduction and started to see just about 19sec after first batch so it was close but still a second off and every batch started losing more time. i got 8min 40sec but still like 30sec off.

 

why wouldnt i be able to do 4m 512 like everyone else, could it be a service i disable.?

Share this post


Link to post
Share on other sites

Unless that service kills your memory bandwidth, it should cause no trouble. Try other memory benchmarks as well to see if the performance is en par. I am still leaning more towards a hardware problem, not a driver or software issue.

 

Also have a look at your NB frequency, 5900 MHz is very high.

Share this post


Link to post
Share on other sites
Unless that service kills your memory bandwidth, it should cause no trouble. Try other memory benchmarks as well to see if the performance is en par. I am still leaning more towards a hardware problem, not a driver or software issue.

 

Also have a look at your NB frequency, 5900 MHz is very high.

 

well with the non-k oc we cant change multi so cpu and cache always same speed. this cpu was doing 6.5ghz last night in all benches gpupi also. i tried slower speeds and it's off. other memory benches work ok. i guess i will try with different mobo tonight.

 

do you have any clue why i would need 1/64 and my 4/512 is so off. like over 7sec a batch. does that point towards anything. the reason its so frustrating is because my cpu can do a 100mhz higher than #1 score so i should have #1 even with bad efficiency, really crazy.

 

i also did switch to win 7 64 bit. i have a asrock mocf so maybe i should try that. i have been going nuts with this for weeks. its a stage in division 3 round 2 also and is making me lose the competition.

 

i also want to say thank you for all your quick replies and being so helpful. sorry if im annoying, its the only bench i cant figure out.

Share this post


Link to post
Share on other sites

I opened the text file in the gpupi folder after doing 2 runs. And it said something like timer speed only 3605097hz and hpet timer not found. I know I have that number wrong but it was something similar. Does this mean anything? I have no hpet option in bios.

 

Last night I turned to a very stable 4.5ghz and 1/64 gives me 25sec after first batch and 4/512 gives me 32sec. I dont finish the entire run because it takes awhile and I can see how far I am still off by first batch time.

Share this post


Link to post
Share on other sites

And it has to be enabled in Windows, see the GPUPI FAQ section again, you'll find a command line statement to switch to HPET.

 

But that has nothing to do with your problem. It's just a more precise timer, but only for a few ms of the measured end time. ;)

Edited by _mat_

Share this post


Link to post
Share on other sites
And it has to be enabled in Windows, see the GPUPI FAQ section again, you'll find a command line statement to switch to HPET.

 

But that has nothing to do with your problem. It's just a more precise timer, but only for a few ms of the measured end time. ;)

 

ya asus stopped putting in bios since the new boards only support back to win 7. I enabled it in the os and it didnt change anything.

 

This is so strange, it's the only bench I have ever had an issue that I couldnt eventually figure out. I guess I should try with different mobo and cpu.

Share this post


Link to post
Share on other sites
Guest PH Benchmarker

Hey guys, i have a problem with my GPUPI, when i run the benchmark, the software crash, i've tried reinstall the Visual Studio 2013 C++, but not solved the problem, who can help me?

 

Hugs.

Share this post


Link to post
Share on other sites

What do you exactly mean with crashing? Runtime assertion? Please specify the exact error message and have a look at GPUPI.log as well.

 

A wrangled OpenCL driver is btw much more common to produce such an error. Please uninstall any driver and reinstall again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×