Jump to content
HWBOT Community Forums

GTX TitanX vs. A/E/G-Power


der8auer

Recommended Posts

mXOjxxl.jpg

 

Over the last 2 weeks I soldered 9 x A/E/G-Power to TitanX cards and I wanted to give a little feedback of what 8 Pack and me experienced while benching a ton of TitanX cards.

 

GIGABYTE GPower

Initially we planed to use 4 x G-Power from GIGABYTE because you can connect the G-Power controller via USB to the system and controll the cards over software. It's easier for 4 cards than using the controller.

 

Following my TitanX-External-Power-Guide I attached one G-Power first and applied the normal FB-Memory mod. However, using 1,75 Volt on the memory the stock VRM died. Probably just bad luck because on all other cards the mod worked without any problems.

As a result I attached the G-Power V2 voltage output to the memory on the card so we can still use it. The problem is that we lost about 200 MHz on the memory moving from stock VRM to G-Power on memory.

Testing the G-Power on the core we always experienced OCP at around 1800 MHz @ 1,6 Volt (all voltages down to 0,0 Volt. G-Power shut down). I first thought it was just a problem with the card itself but we had exactly the same on the 2nd card.

 

So my conclusion about G-Power so far:

+ Software-Control possible

- Don't use V2 at all on memory or you lose MHz. Always keep stock VRM

- You will face OCP. We're already in contact with sofos and Hicookie but so far we couldn't find a solution

 

 

EVGA EPower 2.0

The EVGA EPower works very well acually. We used it on 3 cards and no OCP/OVP or anything else. However, two EPower cards died at around 1,8 Volt and 2k+ MHz on the core. I guess there is no ocp and the power draw was just too much for these cards. On one card we suddenly had a spark near the front MLCC capacitors and eventually one tantal cap blew up:

E5eP02J.jpg

picture courtesy Overclocking TV

 

So I removed the EPower and luckily the card was still alive (GPU resistance ~3 ohm). So I attached our spare EPower which worked fine for about 5 hours. Suddenly bad smell and all LEDs of the EPower shut down. So again - EPower dead. This time there was an internal short close to the mid PCIe-Connector. The ground layer of the EPower near the connector was totally burned so I guess there was an internal short somewhere (forgot to take a picture of this - sorry).

 

So my conclusion about EVGA EPower 2.0:

+ The Board works very well

+ No OVP or OCP

- However we lost 2 out of 5 which seems quite a lot.

- EVGA EVbot needed

 

 

ASUS Power Card

The ASUS Power Card has a very nice design and great features. You can set the voltage directly on the card and you don't have to use an external controller. This is great for one card but using 4 cards with all the cables it's not that easy to access.

Elmor is doing a great job with the development and if you have any feedback or problems let him know!

He also recommended to me to place some additional heatsinks on the inductors and use a very strong fan for TitanX.

We could run 1,8 Volt at over 2000 MHz on the GPU without any problems so the card is indeed very well designed. Just over 1,85 Volt we had OVP which I'm sure Elmor can solve with a new firmware.

 

Conclusion about ASUS Power card:

+ Good design and easy to use

+ No controller needed (good for single/dual card)

+ No OCP

+ Firmware is easy to flash over micro USB

- Difficult to use in 4 way without controller

- OVP above 1,85 Volt.

- Current heatsink is too high for 4-way

 

 

Overall conclusion:

All cards have their positive and negative aspects. In general for TitanX I would recommend EVGA EPower or the ASUS Power Card. However my personal favorite is the ASUS Power card. Simply because it's so easy to use and if there is any problem Elmor can simply send a new firmware to you.

Edited by der8auer
Link to comment
Share on other sites

1,85 set at the Power Card directly

 

Part of it is that you added some sensing modifications we suggested to improve droop conditions, could be part of the reason why this happens. Those mods 1.8V set on the power card would give us 1.76V loaded on the GPU side (just below 2G core, almost 500A average current).

  • Like 2
Link to comment
Share on other sites

Great info, thanks for sharing.

Had used same amount of cards with EPower, zero issues, all cards and EPOWERs alive still after all Vince's abuses.

 

Side note - there is a 4-position DIP-switch on EPower to set voltage as well, so you can control voltage without EVBOT, just not as much precise as with it.

 

EPOWER is product available for sale :)

Edited by TiN
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...