Jump to content
HWBOT Community Forums
Mysticial

Math turns benchmark: y-cruncher meets HWBOT

Recommended Posts

Just a heads up to any staff members who might want to know...

 

I'm planning a March 14th (Pi Day) release of version v0.7.2 of the program next year. And it will not be speed consistent with the current v0.7.1 release. Let me know if this will cause any problems with any ongoing competitions that will cover that date. I can't say what the speed difference is since that isn't set yet, but it will be more than enough to trip up an ongoing competition.

 

The date isn't set in stone and will depend on the stability of the program in the preceding month. But it is the date that I tend to aim for since it's Pi Day.

Share this post


Link to post
Share on other sites

I did actually make it in time. Version 0.7.2 has been released. Happy Pi Day everyone!

 

This new version is faster than the previous version on pretty much all processors that I've tested on.

For internal reasons, you are now required to use the latest submitter version (v0.9.6).

 

Here are some submissions from the Ryzen build that I used to tune for Zen.

 

Share this post


Link to post
Share on other sites

No client version given, required version: 0.9.6 ?!

 

Using 0.9.6.114, submit through the interface.

Edited by borandi

Share this post


Link to post
Share on other sites
No client version given, required version: 0.9.6 ?!

 

Using 0.9.6.114, submit through the interface.

 

I'll investigate tonight. I pushed an update a few days ago, but it's certainly possible that I broke something.

Share this post


Link to post
Share on other sites
No client version given, required version: 0.9.6 ?!

 

Using 0.9.6.114, submit through the interface.

 

I can't reproduce the issue. Submissions work fine for me. Can you give me more information? Such a screenshot of the error?

Share this post


Link to post
Share on other sites

If anyone's wondering about AVX512. It's coming... No ETA yet since I've hit a number of unexpected snags.

 

2017-7-1.jpg

 

If you're wondering why the chip is underclocked. There's a reason for that. And it's a long story.

Don't worry, it's much harder to fry your chip with AVX512 than I'm making it sound - unless you disable thermal protection...

Share this post


Link to post
Share on other sites

And version 0.7.3 is out.

 

And here are the first few submissions on a Core i9 7900X @ 4.0 GHz (all-core AVX512) and memory @ 3200 MHz:

 

The AVX512 didn't bring as much of a speedup as I'd hoped. But it's still enough to beat all the Haswell and Broadwell HEDTs and come within arm's length of the dual-socket servers.

Share this post


Link to post
Share on other sites

I will create an internal task for richbastard, we just implement a new server and hwbot revision, might be because of this

Share this post


Link to post
Share on other sites

This is getting fixed on both sides. richba5tard says a server-side push tomorrow will change the default from XML back to JSON.

 

At the same time, I've updated the HWBOT Submitter to explicitly request JSON.

 

Here the first submission of the new y-cruncher version that I released yesterday (and re-released just now with the fixed HWBOT Submitter):

 

http://hwbot.org/submission/3766703_

Edited by Mysticial

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×