Jump to content
HWBOT Community Forums
Christian Ney

HWBOT GPUPI for CPU - 100M Benchmark Validation Regulations

Recommended Posts

Then where do I get V3.1+? The link only has V3.3.2. Is anybody going to do anything about this? Or are we just not doing GPUPI anymore? I'm so lost. Please explain. Thanks! PS, V3.3.2 doesn't even work...AT ALL!!! So you don't need to worry about that POS.

Share this post


Link to post
Share on other sites

If you search for GPUPI on the web you will find my site with all versions to download: https://www.overclockers.at/news/gpupi-international-support-thread

The problem that's confusing everybody is the fork of GPUPI (3.2 and 3.1, gets points) and GPUPI 3.3 (no points). I can only accept the fact, but I am definitely not a fan of this.

I would advise to not bench GPUPI 3.3 currently. I am working on GPUPI 4 that will improve a lot of things, especially benchmark security and timer precision/reliability. It will also get rid of the plagued OpenCL implemtations for CPUs, so it will work out of the box in the future. No need to install any OpenCL driver.

  • Like 2

Share this post


Link to post
Share on other sites

I have updated the download page on overclockers.at to reflect the situation on HWBOT better. Let me know if that helps.

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
How to run this bench for the CPU? When I click the Calculate menu, it only allows me to select my Graphics card, so I can't run it for the CPU.

Share this post


Link to post
Share on other sites

Got an AMD/ATi graphics card? I've found the best way to get OpenCL for CPU working is installing the Radeon Drivers prior to 18.8.1 (I think) Lately I've been using 18.5.1. Otherwise you can try your luck with the various OpenCL SDK packages that can be found on the net. Check out the GPUPI page on Overclockers.at. Alternatively you can try Intels OpenCL package. Links at the page mentioned.

Edited by cbjaust
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Install the intel openCL and whatever AMD openCL you prefer and GPUPI will give you the option to run either Intel or AMD OpenCL.

And it works everytime whatever AMD openCL you desire to use 

  • Like 1

Share this post


Link to post
Share on other sites
@cbjaust Yes I have an Radeon 570, but i don't plan to install older VGA drivers just to run this bench.Thanks anyway @macsbeach98 I just need the Amd opencl. All i find online is the whole SDK at almost 300mb. There is not a simple driver file or something?

Share this post


Link to post
Share on other sites
@_mat_ I have downloaded the "AMD APP SDK 3.0 (OpenCL 2.0)" file and during the installation, I have selected the first option "OpenCL Runtime libraries", but still no option to select my CPU at the benchmark. Maybe I have to install something more?

Share this post


Link to post
Share on other sites

As stated above your AMD GPU driver is overwriting the OpenCL entry for the CPU. In the posts above you are good countermeasures.

Share this post


Link to post
Share on other sites
New 2020 scores: Require CPU-Z 1.91 or newer version New 2020 scores: Full desktop screenshot required ( no clipping)

Share this post


Link to post
Share on other sites
Any updates for 2020? New adrenaline drivers are out. Is it still required to run old graphics drivers to be able to run it?

Share this post


Link to post
Share on other sites

Hello everyone,
For win7 is the procedure the same or maybe it's a bit more easy?

Share this post


Link to post
Share on other sites

No clue. Try to avoid Windows 7 for Compute benchmarks though.

Share this post


Link to post
Share on other sites
Submit mode doesn't work for me at Win7. 2 times I tried to submit the results through the integrated process and both times I have received an Application error message something about instruction at memory 0x00000000 and that the memory could not be written. And I lost the results.

Share this post


Link to post
Share on other sites
On 3/5/2020 at 1:39 PM, viper said:

Submit mode doesn't work for me at Win7. 2 times I tried to submit the results through the integrated process and both times I have received an Application error message something about instruction at memory 0x00000000 and that the memory could not be written. And I lost the results.

Suggest you just save the submit file instead and upload that separately. It usually works.

Share this post


Link to post
Share on other sites

Small update.

I have unticked the boxes for the CPU and GPU at the results screen and it allowed me to save my results normally..

Go figure. I thought that it's recommended to have them selected.

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, viper said:

Small update.

I have unticked the boxes for the CPU and GPU at the results screen and it allowed me to save my results normally..

Go figure. I thought that it's recommended to have them selected.

nope depends on hardware, OS, SDK driver used… sometimes even running HWINFO in save mode helps to save... you just have to check if it saves properly before any serious benching

  • Thanks 1

Share this post


Link to post
Share on other sites

Happy Easter to everyone.

Unfortunately lately it doesn't allow me to save or submit anything any more on win7.

It just gives the message that the app stopped working and it's closing down. I have tried any possible combination with ticking or not the boxes and the result remains the same.

Is this ever going to be fixed? 🤔

Share this post


Link to post
Share on other sites
On 1/6/2020 at 12:51 PM, Leeghoofd said:

Matt is working hard on GPUPI 4.0, no need to redesign this version.

 

  • Like 1

Share this post


Link to post
Share on other sites
On 3/9/2020 at 6:38 AM, viper said:

Small update.

I have unticked the boxes for the CPU and GPU at the results screen and it allowed me to save my results normally..

Go figure. I thought that it's recommended to have them selected.

So what did you change  from when it was working? That's the main question you need to ask yourself. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...