Jump to content
HWBOT Community Forums

G.Skill F4-3200C14Q-32GVK or X99 SOC Champ causing the problem?


Recommended Posts

Hi guys


Just built my X99 SOC Champ but it's not posting, each time it fails at 60 on the debug display, not sure if it's RAM,CPU or Motherboard. The manual says DXE initialise whatever that is.


Can anyone help?


I've tried running one stick of RAM in the slot stated in the manual (all 4 sticks separate from each other) but that didn't help I've tried a couple sticks as well together but again It does the same gets to 60 then restarts over and over again.


My memory is G.Skill 3200MHz CL14 32GB (4*8GB) quad channel kit Ripjaws V


I dont have any other RAM or CPU to try, thinking I could buy another RAM kit to test see if it does the same, any other suggestions would be welcome



Link to comment
Share on other sites

  • Administrators

This is an awkward situation, if you cannot lend other Ram this is difficult to solve when not even one stick boots. I would normally rule out the memory is defective, the chance 4 sticks are doa is 1:999 imho. So it is either compability or cpu/board. Best idea is to get some standard 3200 c16 or 2133 c15 sticks that allow you to test not only function of board and cpu at a "less complicated" spd/xmp in my opinion but also might give you the chance to dial in booted settings by hand and simply swap the sticks against your 3200c14 for cross checking

Link to comment
Share on other sites

Thanks for posting mate.


I've bought another RAM kit, it's a corsair 2400MHz quad channel kit. It's on Gigabytes QVL so it should def be compatible. They'll arrive monday so I'll try those and take it from there.


Hopefully they'll work then I can see what BIOS is running on the board and update if necessary then I'll try my G.Skills again

Link to comment
Share on other sites

  • 2 weeks later...
I have that exact kit F4-3200C14Q-32GVK, working no issue on SOC champ with 5960x and 5820k. Running F4m bios, also tried newer F20 series (don't remember exact number) without issue.


Oh right, not sure why they didn't work for me. Once I put F22m BIOS on I've not had any problems running them. However I can't get more than 3200Mhz no matter what! I've tried 3250Mhz and it won't even post. Tried VSA at +0.3v and even tried DRAM at 1.72v. Only thing I have left to try is looser timings.


Have you had any luck going higher with the kit?

Link to comment
Share on other sites

For me on haswell-e its harder to run more than 3200ish mhz. However tightening timings with bdie is no problem. 10-10-10 1t with iol set to 1 (lowest soc champ will go) is easy.


How do you set the iols, theres a list of 4 of them in BIOS, do I just put 1 in all of them then save and exit and let it train?


I take it you don't use XMP and configure it all manually? Do you have Primary Timings set before you pop in iols or is everything on auto first?


I'm very newb when it comes to memory, I've only ever gone for most clock frequency and tighten up Primaries as best I can lol I also shoot for 1T too.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...