Jump to content
HWBOT Community Forums
TAGG

Strange behaviour when using SetFSB

Recommended Posts

I just discovered a strange issue when raising FSB using SetFSB in Win XP, when I add more than 5MHz of FSB the multiplier starts to drop.

This only seems to appear in XP, I used the same version of SetFSB in Win 7 x64 and it worked just fine (both CPU-Z 1.85)...

Setup used was a ASUS P5E64-WS EVO and a Pentium E5800 but I also had the same issue on a EP45-UD3R but with 10MHz above boot-FSB...

EDIT: Seems like a CPU-Z bug, CPU-Z 1.63 displays the right multi, but I can't use that to validate for obvious reasons :(

EDIT2: The CPU itself isn't lowering clocks at all, spi runs are nearly the same within the 1MHz where the bug accurs...

Anyone ever had a simmilar problem and might know a fix?

Any help would be greatly appreciated :)

Edited by TAGG
  • Thanks 1

Share this post


Link to post
Share on other sites

Huh, nice testing. I noticed it on a Celeron 430 IIRC, but it was while I was binning so didn't test any benches. I found booting higher helped prevent it from occuring as soon; not a solution but the best I could find at the time.

Share this post


Link to post
Share on other sites

Interesting, not something I remember having issues with (using EP45-UD3P).

Will keep an eye out next time I'm doing 775.

Share this post


Link to post
Share on other sites

Yep booting higher helps but only linear i.e. booting 400MHz instead of 395 lifts the bug to 405 instead of 400...

I will try a brandnew XP install tomorrow...

At least it's  only a display bug, so benches are not affected, you just need to use antique CPU-Z to have the right Frequency displayed :)

 

Share this post


Link to post
Share on other sites
44 minutes ago, TAGG said:

Yep booting higher helps but only linear i.e. booting 400MHz instead of 395 lifts the bug to 405 instead of 400...

I will try a brandnew XP install tomorrow...

At least it's  only a display bug, so benches are not affected, you just need to use antique CPU-Z to have the right Frequency displayed :)

 

What happens if you open 1 window of old correctly working cpuz (leave open), then open the new required version. Does it show correctly? If yes then you can open rest of cpuz windows you need, then close the old version and take your screen shot. This is a trick that fixed weird issue with AFD on mocf for kabylake. No idea if it will work for you but worth a shot.

Share this post


Link to post
Share on other sites

Doesn't work, neither does the win98 version or anycombination of settings in the ini. file.

As soon as you hit the threshold of 5MHz new CPU-Z displays one multi lower no matter if you have it open during changing FSB or if you open it afterwards if you had old CPU-Z open...

Share this post


Link to post
Share on other sites
21 hours ago, TAGG said:

Yep booting higher helps but only linear i.e. booting 400MHz instead of 395 lifts the bug to 405 instead of 400...

I will try a brandnew XP install tomorrow...

At least it's  only a display bug, so benches are not affected, you just need to use antique CPU-Z to have the right Frequency displayed :)

 

Technically don't you need to show the freq that you benched at?

Share this post


Link to post
Share on other sites

Yes but which CPU-Z i use for taht doesn't matter, just for validation that's a problem :)

Share this post


Link to post
Share on other sites
9 hours ago, unityofsaints said:

I am seeing the same on the Rampage III Extreme with locked CPUs.

On 1366 you can get around it by upping the multi using Throttlestop. I've seen this issue on 775 (P5Q Deluxe and EP45-DS3) as well as on various 1366 boards (at least Rampage II Extreme, x58a-oc and x58a-UD7) and also on 1156 (H55m-UD2h and P55-USB3)

Share this post


Link to post
Share on other sites

You can bug it in the other direction as well if that helps as motivation to fix it, lowering bclk raises multi to impossible levels (see attached pic)

IMG_20190203_155733.jpg

Share this post


Link to post
Share on other sites

It's not unique to Intel either. On Ryzen on certain boards and multi combos CPU-Z will suddenly show 80 BCLK and wrong mult but right frequency. Very annoying when you are on LN2 and need a valid screenshot. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×