Jump to content
HWBOT Community Forums
avalanche

Tweak book for cheats

Recommended Posts

9 hours ago, Matsglobetrotter said:

Snip

 

 

 

 

 

 

 

 

What happened to the old meme thread? There was definitely one about "I don't understand the tweak - ban the benchmark" 

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, ObscureParadox said:

Apply the same fix as GPU-PI with the timer.

If you mean something other than switching to HPET - which I think you do - please enlighten the ignorant (me 😉

Share this post


Link to post
Share on other sites
1 hour ago, marco.is.not.80 said:

If you mean something other than switching to HPET - which I think you do - please enlighten the ignorant (me 😉

  • Run CMD as admin and paste “bcdedit /set useplatformclock yes
  • Thanks 1

Share this post


Link to post
Share on other sites

Ok, so you were talking about HPET - so no secrets to be gleaned? Darn! I so badly want to run GPUPI on my Skylake and above processors without having to swtich to HPET which in some cases makes my entire system hiccup and stutter making it difficult to compete on that benchmark and others which foce us to use HPET.

  • Like 1

Share this post


Link to post
Share on other sites
35 minutes ago, marco.is.not.80 said:

Ok, so you were talking about HPET - so no secrets to be gleaned? Darn! I so badly want to run GPUPI on my Skylake and above processors without having to swtich to HPET which in some cases makes my entire system hiccup and stutter making it difficult to compete on that benchmark and others which foce us to use HPET.

Using windows 7 can run without HPET

  • Like 1

Share this post


Link to post
Share on other sites
40 minutes ago, marco.is.not.80 said:

Man, I tried just the other day with Windows 7 and GPUPI simply wouldn't allow it. What am I doing wrong?

I find gpupi a pain to get working compared to a lot of benchmarks, did you try different versions, what was actually going wrong?

Share this post


Link to post
Share on other sites
6 hours ago, marco.is.not.80 said:

Ok, so you were talking about HPET - so no secrets to be gleaned? Darn! I so badly want to run GPUPI on my Skylake and above processors without having to swtich to HPET which in some cases makes my entire system hiccup and stutter making it difficult to compete on that benchmark and others which foce us to use HPET.

No HPET necessary for Intel CPUs >= Skylake. Just use GPUPI 3.2 or above with Windows 10 RS4 or below.

In RS5 it is currently not working because it changes the timer frequency of QPC to 10 MHz instead of the previous bootup frequency. So GPUPI 3.2 can't detect the usage of RDTSC correctly in RS5.

Also no need for bcdedit, just open GPUPI, goto menu "Tools" => "Enable HPET". Reboot and you are good. You can also switch it back there.

2 hours ago, GeorgeStorm said:

I find gpupi a pain to get working compared to a lot of benchmarks, did you try different versions, what was actually going wrong?

OpenCL is the main problem right now. It's a mess.
The timer restrictions are necessary and good. Won't apologize for that. 😛
 

Btw, GPUPI 4 already uses a driver to directly access HPET and there is not need for OpenCL for CPUs anymore. Current status:

1207852491_GPUPI4Alpha3.thumb.png.87673cd6389b1f51602b1c907a5671fa.png

Edited by _mat_
  • Like 2

Share this post


Link to post
Share on other sites
9 hours ago, _mat_ said:

No HPET necessary for Intel CPUs >= Skylake. Just use GPUPI 3.2 or above with Windows 10 RS4 or below.

In RS5 it is currently not working because it changes the timer frequency of QPC to 10 MHz instead of the previous bootup frequency. So GPUPI 3.2 can't detect the usage of RDTSC correctly in RS5.

Also no need for bcdedit, just open GPUPI, goto menu "Tools" => "Enable HPET". Reboot and you are good. You can also switch it back there.

OpenCL is the main problem right now. It's a mess.
The timer restrictions are necessary and good. Won't apologize for that. 😛
 

Btw, GPUPI 4 already uses a driver to directly access HPET and there is not need for OpenCL for CPUs anymore. Current status:

1207852491_GPUPI4Alpha3.thumb.png.87673cd6389b1f51602b1c907a5671fa.png

I mostly want to see a comparison of 3.3 and 4.0 as those are two latest versions and it would suck balls if we had 3 different speed GPUpis.

My 1,000th post has the phrase "suck balls" in it, nice :D

Edited by unityofsaints
  • Like 1

Share this post


Link to post
Share on other sites
13 hours ago, _mat_ said:

No HPET necessary for Intel CPUs >= Skylake. Just use GPUPI 3.2 or above with Windows 10 RS4 or below. 

In RS5 it is currently not working because it changes the timer frequency of QPC to 10 MHz instead of the previous bootup frequency. So GPUPI 3.2 can't detect the usage of RDTSC correctly in RS5.

Ah, this is explains things very clearly, thank you! So - with Windows 7 HPET is always necessary, Windows 10 isn't but if I'm running the latest release it won't allow me to run without HPET. Got it. Thanks, Mat!

Share this post


Link to post
Share on other sites

You misunderstood my past post. With Windows 7 GPUPI is falling back to RTC which is safe on all platforms but the EVGA SR-2 (you will be notified if it's detected). So normally no need for HPET on Windows 7 for GPUPI!

On Windows 10 RS4 and before you don't need HPET if you are running Skylake or higher. All other will need HPET because RTC and RDTSC are not safe on Windows 10

Windows 10 RS5 needs HPET enabled on all platforms currently because QPC frequency was changed and GPUPI can't detect it yet!

  • Thanks 1

Share this post


Link to post
Share on other sites
11 hours ago, unityofsaints said:

I mostly want to see a comparison of 3.3 and 4.0 as those are two latest versions and it would suck balls if we had 3 different speed GPUpis.

My 1,000th post has the phrase "suck balls" in it, nice :D

GPUPI 4 will be equally fast on GPUs, but faster on CPU when using the native path without OpenCL. That's my goal and it's necessary to leave OpenCL behind once and for all.

The 3.3 categories should then be renamed to 4.0 (or 3.3+) to host all new GPUPI versions.

The whole situation kind of sucks balls, I should have never released 3.3 so early. Would have been better to release the optimizations with GPUPI 4, but we are all smarter afterwards, right?

  • Thanks 2

Share this post


Link to post
Share on other sites

Honestly can't wait that the point relevant bench isn't 3.2 anymore... Because i have spent countless hours trying to get 3.2 to either save the file without crashing or displaying hwinfo correctly, while 3.3 allways just worked for me...

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, TAGG said:

Honestly can't wait that the point relevant bench isn't 3.2 anymore... Because i have spent countless hours trying to get 3.2 to either save the file without crashing or displaying hwinfo correctly, while 3.3 allways just worked for me...

Same here, I loath running 3.2 because I know that most of the time it won't work at all or it will crash when saving the file. Which btw is a pain when your doing 1B on a P4 and it takes an hour to do.

3.3 on the other hand always worked perfect plus it's faster so I can spend more time tweaking instead of sitting around running the bench.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

For me,  it will save the score locally but will crash when I try to upload it to the Bot. I have not tried the new version as it did not have point's for it. I will give it a try if it loses OpenCL because of problems with it. Install AMD video card and it works. Uninstall the driver with DDU. Install a Nvidia GTX-5xx with drivers. GPUPI 3.2 refuses to run because of an OpenCL xxx.ddl file not found.

I don't need OpenCL when running a Nvidia card as CUDA is faster. I have found that installing the Intel OpenCL driver allows me to get around this error.

Edited by MaddMutt

Share this post


Link to post
Share on other sites

The crash during the online submission in GPUPI happens because of this problem: 

It should be possible to fix it on the bot side of the interface. In any case I have already improved the online submission in GPUPI 4 to avoid crashes like these.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...