Jump to content
HWBOT Community Forums
funsoul

Gpupi for cpu: How to set up?

Recommended Posts

Hi folks!

Am SO frustrated!!! :( I just cannot seem to get this darn thing running. Have tried with both existing as well as sparkling clean builds but keep getting a variety of issues so haven't been able to run this for ages on any platform. 

Is there a step by step guide? From what I gather, the new intel version of opencl is the most efficient. That said, which darn file(s) do I need? 

Atm, trying to get it working for z97 but have the same problems on every platform I've tried. 

What the heck??

Tia!

Share this post


Link to post
Share on other sites

What are the problems you are refering to? Without a detailed description it's difficult to help.

As for step by step for Intel CPUs:

  1. Download the latest Intel OpenCL runtime: https://registrationcenter.intel.com/en/forms/?productid=3207
  2. Open GPUPI, "Calculate", select your CPU in the latest Intel OpenCL platform you can find in the settings dialog and run.

There could be inconveniences regarding your OS timer, where GPUPI states that you can't submit due to possible timer skews. Either enable HPET (GPUPI 3.3 will give you that opportunity by just pressing a button) or run Windows 7 or Windows 10 prior to RS5.

Share this post


Link to post
Share on other sites

Thanks mat!

At launch, I always get the following error:
Name:  gpupierror1.jpg Views: 56 Size:  338.2 KB

Googled around and found that "the fix" is to copy the opencl.dll files from the amd folders to the system32 and syswow64 folders. That gets gpupi working but my times are horrendous (like 30 places lower than where the chip should score). Take a look at this screenie....cpu is at 6.7GHz, notice there's no opencl version message at the top of the gpupi window and hwinfo failed (I know it's not needed but it's another, likely related issue).

Tried on a clean 7x64 build with an nvidia card, installed the intel opencl for visual studio, various c++ but then gpupi wouldn't even open (can't recall that error atm, though). 

Actually got the app to start once but it threw an error when I tried to start the calculation. 

Not sure what the heck I'm doing wrong 

Share this post


Link to post
Share on other sites
30 minutes ago, funsoul said:

gpupierror1.jpg

This error is because your opencl doesn't support opencl 2.0

You need to install amd sdk v3.0+ or intel 18.1

Gpupi 3.2 legacy will work with opencl 1.2

Edited by bigblock990

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×