Jump to content
HWBOT Community Forums

Asrock Z170 OCF RAM won't boot above 3000MHz

Recommended Posts

I'm struggling to get an Asrock Z170 OC Formula motherboard to boot a 4500 RAM kit (TeamGroup TForce xtreem) at anything above 3000. I've tried two different 7700k's.

On an MSI motherboard the RAM is fine at 3600 with the same CPUs so I must be missing a setting in the BIOS or something.

I've even gone through the BIOS RAM pre-sets and all of the ones at or below 3000 POST fine even the super tight ones. The second I change it to 3066 or above, no POST.

Any help is much appreciated  :)


Edited by Sam__
Link to comment
Share on other sites

If they use A2 PCB, at least on Z170M OCF (microatx OC Formula) motherboard you had to enable XMP first and then make adjustements to make them play nice. So try this too ... enable XMP, and with XMP enabled manually set frequency + primary timings and the other timings you want.

Edited by BoTSkill
Link to comment
Share on other sites

Thanks for the idea. I just tried booting with XMP enabled at 3000 and it was happy. Then increased it to 3066 and no go :(.

I also tried a single DIMM (was using two before) in each slot and found the max freq in each slot.

A1: 2933
B1: 3000
A2: 2900
B2: 4133

For some reason it likes B2, which is the slot Asrock recommend when using high freq RAM. But I would really like to run dual channel if possible.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...