Jump to content
HWBOT Community Forums

error trying to submit results of pcmark10


Recommended Posts

I keep getting an error while trying to submit my validation file - This :  (  Validation error: A valid futuremark compare url is required if want to reach the PCMark10 Express Hall Of fame. As only 3 benchmark scores are better than you, you need to provide additional verification. ) 

 

The url is correct and the run is 100% valid. I tried entering without the https and use only www. but it is not working. Please @Leeghoofd or any mod can you check this bug and approve this sub ? Thank you.

 

http://www.3dmark.com/pcm10eb/53494

 

 

4.png

Link to post
Share on other sites
  • Crew

UL/Futuremarks links all over the place to be honest, Oziv and Matts score work fine straight from UL... now this one adds eb again to the link? Need to check with Pasi what the deal is here

  • Thanks 1
Link to post
Share on other sites

 

Seems the system works with the initial link created with the upload https://www.3dmark.com/pcm10/57209496

But then dont work with the  personal link generated for users logged in http://www.3dmark.com/pcm10eb/53559

meanwhile you get very interesting results using the http://www.3dmark.com/pcm10/53559   link on 3dmark 

 

for now I put the initial link in the sub and then the personal link in comments

  • Like 1
Link to post
Share on other sites
19 hours ago, Matsglobetrotter said:

 

Seems the system works with the initial link created with the upload https://www.3dmark.com/pcm10/57209496

But then dont work with the  personal link generated for users logged in http://www.3dmark.com/pcm10eb/53559

meanwhile you get very interesting results using the http://www.3dmark.com/pcm10/53559   link on 3dmark 

 

for now I put the initial link in the sub and then the personal link in comments

Same here today i have the same issue. I just did the same as you and in the comments i placed the correct link.

Link to post
Share on other sites
  • Crew

Pasi replied this, I'll contact our programmer if he can adress this. 

 

Effectively every PCMark result has two URL's (current 3DMark ones are actually the same way).

One is based on the id number of a database table that has an entry for every PCMark 8, PCMark 10 or unified 3DMark client submit - https://www.3dmark.com/pcm10/57209496

So, 57209496 is what we call internally a benchmark run id, it's just incremented by one for every result that comes in, so you can tell from the ID that we've had in total 57.2 million 3DMark (Ice Storm, Cloud Gate, Fire Strike onwards), PCMark 8 or PCMark 10 submits.

Every current 3DMark client result has a url under /3dm/ where the ID numbers come from this same benchmark run id space, for example this Port Royal result https://www.3dmark.com/pr/668252 is also here https://www.3dmark.com/3dm/55246388 .
 
http://www.3dmark.com/pcm10eb/53559  on the other hand is a test specific URL for PCMark 10 Express and 53559 is the results PCMark 10 Express ID (so we've received 53k PCMark 10 Express results). 
 
Why this setup exists is that initially we supported running multiple tests with the same run and indeed the default run when we launched the current 3DMark client ran all of Ice Storm, Cloud Gate and Fire Strike, and a run like that would have one run ID and also separate IDs for all the individual tests that were part of it so we knew what tests were run together. So while today we have two URLs that give the same page, we used to support this type of result page for a run with multiple test results from different tests: https://www.3dmark.com/3dm/50000 .

So, I suppose the issue at hand is that the site shows you the /pcm10/ style url when you first submit, but after that there is no way to get back to it as the user never sees the run ID anywhere and you can only get the test specific URLs from your result history. 
 
If you need to have "one true URL" or a canonical URL, the /pcm10eb/ should probably be used for Express so everyone can get the link for old results as well (as said in the thread, for your own results it's the one shown in the "Link to this result" -box). You can also generate that type of URL for any other result even if it's not yours as the test specific ID in the URL is the one shown on the page. 

image.png
 
Or you could just support both types of URL for PCMark 10 submits.
 
On the database level the two URLs point to the exact same result so whatever happens to one, happens to the other, so they are exactly equivalent.
  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...