Jump to content
HWBOT Community Forums

My Llano setup: GIGABYTE UD4H + A8-3870


Massman
 Share

Recommended Posts

Introduction

 

Not much to say about this topic so far. I just wanted to test Llano because from other people's results it looks like quite a lot of fun. Also, I needed a reference system for the GIGABYTE A75 OC Challenge.

 

First I did a bit of testing on air cooling and then went to liquid nitrogen. But, so far the results are not satisfying for me. I need to spend more time on this platform to figure out how to work around its limitations. I will need to read up on The Stilt's findings, for instance.

 

Pictures

 

th_SAM_0313.jpg th_SAM_0315.jpg th_SAM_0316.jpg th_SAM_0317.jpg th_SAM_0318.jpg th_SAM_0319.jpg th_SAM_0321.jpg th_SAM_0322.jpg

 

First results

 

(cannot find the air results at the moment, will update later)

 

th_7878.png th_8456.png th_1436800.png th_15640.png th_15837.png th_16349.png th_16739.png th_1742081.png th_1853966.png th_2367.png th_2426.png th_2498.png th_2509.png th_270302.png th_8410.png th_9011.png

 

Thanks to:

 

As always, thanks to TONES for the support.

 

tones-logo-20062.jpg

Link to comment
Share on other sites

  • 5 months later...

I was going to post this in the BIOS thread, but this seems just as fitting (it not more) a place:

 

Has Giga not included anything for changing of the CPU-NB multiplier, or did my modding of the BIOS to always make it available break it's operation?

 

I unhid it's option so it is always there because the speed is not correctly set on these Giga boards it seems (UD4H specifically). I had the ASRock A55 Pro3 previously but it died, yet it had the CPU-NB speed available to set even on my 3850, and at DDR3-1866 it would auto set to the highest available (900-some, or 9x IOW). Even at 1866 on the UD4H, it is only running at 720MHz (7.2x multi), which AMD has said they set up the APUs to run almost 1:1 with the DDR speed. So 1866, or 933 actual, should be running at 9xxMHz CPU-NB, even on the 3850s. That's what I modded the BIOS for, to include that, but it's function doesn't impact the speed any :( I tried lower than 9x down to 5x, but it was always at 7.2x! :mad: Even with the 3870K I can't seem to adjust it, but I've not tried the unmodded F7 to confirm that.

 

Also the damn Write performance on this UD4H is HORRIBLE. The most I've been able to get, which is at DDR3-2300 BTW, is a pathetic 9200MB/s... With that ASRock A55 Pro3 it's an amazing 12000MB/s!!! :eek: That's a huge difference! That's in AIDA64, and in Sandra the Pro3 was 22GB/s, with only 18.5GB/s on the UD4H :rolleyes:

 

One thing I did notice on the Pro3 though, is if I disabled the additional ASMedia onboard SATA3 controller, my Write performance took a huge dive, to exactly where the UD4H is at :confused: Why on earth that is, I have no idea, but it's rather strange. All across the board that Pro3's memory performance is more than the UD4H and that doesn't make sense IMO heh UD4H obviously OCs tons better though!

 

Also not exactly sure about the temperatures. I'm using a VERY capable cooler and yet the board (through Windows) is reporting reaching up and over 70C, depending on voltages... On the Pro3 and a much smaller heatsink I don't think it ever reported breaking 55C (at 3.5GHz, 1.42V), but it easily breaks 60C on the UD4H. That's even with a fan blowing directly on the back of the motherboard :\

Link to comment
Share on other sites

What drive are you using?

 

BTW i thought i saw the CPu NB multiplier in there on the UD4H, but now that I look at it its not there.

 

What do you mean by "drive"? Hard Drive, optical, memory drive strength :confused:

 

The CPU/NB multiplier was available in previous bios than F7 as far as I know, but yeah it's no more there in the F7 bios.

 

That's strange and doesn't make much sense to me :\ At least by traditional thinking it doesn't. I see it as the old CPU-NB that it just can only be set so high before you lose stability or the system POSTing, so on locked chips you need to be able to lower that in order to keep it in a stable speed range. Yet on the flip side, if these chips have a CPU-NB that simply doesn't have a limit at which OCing the FSB/HTT will reach, then I can understand removing it; however, there is still the issue of Gigabyte locking it at only 720MHz, even while running DDR3-1866 where it should be 900MHz...

 

 

Didn't they get rid of the option because you simply can't change the CPU-NB ratio?

 

It's been a while since I ran Llano, though.

 

There shouldn't be any reason to not be able to change it on these (mostly) unlocked A8-3870K chips though, so removal of that option is a bit odd.

 

You can change it on my 3850 though, as I was able to on the ASRock A55 Pro3, though that didn't offer multipliers. It's method was rather user friendly by automatically setting the speed to the max when the memory speed was set as so:

(these speeds are not verbatim as I always ran at 1866)

At DDR3-1333 it only allowed a CPU-NB of 720MHz or lower

At DDR3-1600 it only allowed a CPU-NB of 840MHz or lower

At DDR3-1866 it only allowed a CPU-NB of 900MHz or lower

 

So the ASRock A55 Pro3 at default FSB while set to DDR3-1866, the CPU-NB speed was 1800MHz. I think I figured that either that board's FSB limit, or my memory's, was around 124MHz. That ended up giving me a CPU-NB of 1116MHz, or 2232MHz effective, and a DDR3 speed of 1153MHz (2306MHz effective).

 

However, the UD4H (so far with my modded F7) while at 131MHz FSB only was running the CPU-NB at 943MHz, or 1886MHz effective, with the DDR3 running at 2445MHz! :( That CPU-NB is about what it should be at the default DDR3-1866 :\

 

I'll grab F6, first flash the unmodified F7 and test, then flash to F6 to see what's what.

Link to comment
Share on other sites

my drive is a van..lol

 

haha Is the Honda City considered a van? Mine, then, is technically a 1993 Firebird Formula 5.7L (350) :D:nana::banana:

 

To stay on topic though... lol

 

Got F6 downed and will give this a go a bit later; stuffs to do!

 

I assume there is no F8 Beta/Alpha in the wild yet?

Link to comment
Share on other sites

Not that I know of.

 

If I remember correctly, the very first release bioses had CPU-NB clock control. But, it's not really interesting to test them as they had plenty of other issues.

 

Btw, if possible you should post screenshots here from the gigabyte and asrock board (if you still have them). I'm sure the folks at GBT will pick up on this ... ;)

Link to comment
Share on other sites

Not that I know of.

 

If I remember correctly, the very first release bioses had CPU-NB clock control. But, it's not really interesting to test them as they had plenty of other issues.

 

Btw, if possible you should post screenshots here from the gigabyte and asrock board (if you still have them). I'm sure the folks at GBT will pick up on this ... ;)

 

The ASRock board unfortunately died on me (power phase area I believe) so I can't get any more data or screenshots from it. All I have are that which made it into my review and the various tidbits that didn't. So if you were thinking of something specific let me know and I'll see if I happen to have that.

 

As for the UD4H, I'm open to supplying whatever I can! I'd love to get it on par with the Pro3's write performance, as that really puts a damper on my mood lol We bought it to review the 3870K, and I was hoping it would be a kick ass board. Which so far in most regards it is, but the BIOS is not what I expected (though I knew it wasn't UEFI), and just strange it is being outperformed by a budget board more than half it's price :o Does great with overclocking so far. I'm still learning the quirks of the APUs, but it'll make it to the Windows boot loader at 4GHz, also at DDR3-2500, but that's it. Dunno if I can get the DDR3 stable at that since there are issues with something (board or modules) when setting timings higher than Cas 11. Won't POST at 12 or 13 (thus, won't post on Auto timings since it's 13-13-13) *shrug*

 

I'll also look into messing with storage controller settings to see if it magically effects performance like it did with the Pro3. Suppose I should go fiddle with things now... I'll report my findings.

 

Let me know what sort of screenshots you're interested in.

Edited by Formula350
Link to comment
Share on other sites

Awesome... The backup BIOS does _nothing_ on this board! :( :(

 

On my 890GA-UD3H board if I had a bad flash, the board would boot up and give me some message about the Checksum being bad, then recover from the backup. This board... Not a thing, doesn't even POST *cries* Went from a dead board and not being able to review the 3870K, to now a bricked board and will have to wait a few weeks before getting it back :(

Link to comment
Share on other sites

With the X79-UD7, I found there were two settings related to memory bandwidth that had to be disabled rather than enabled to boost performance. It might be something like that.

 

Not sure if I have a working A75 lying around to help figure out things, let me check.

Link to comment
Share on other sites

so you know the BIOS is dead? You think the board is deaD? There is a way to short the main BIOS so that the backup kicks in through fail-safe, but its not really recommended. It should auto-recover, did a flash messup?

 

I let it sit powered on for about an hour and I could hear it (in the background) in a reboot loop ever 5 seconds or so, which coincided with a flicker of the HDD LED. I tried everything to get the system working, but the USB slots don't get any power to do a Recovery Flash via thumb drive, the Optical drive isn't being accessed for a Recovery Flash on a Bootable CD and the shorting of BIOS pins I tried but I have no idea which pin/s to do since it's far different from the board the original trick worked on :\

 

Yea it was a borked flash, which I know it should auto recover, as my 890GX has done it for me but it isn't doing it on this board :(

 

yes disable bank/memory interleaving helps

 

Didn't help mine any. That is just for helping memory overclocks, at least from everything I've been reading. Eitherway, the Pro3 was always enabled, and it was the Disabling of the add-in SATA-III chip (ASMedia) that is what caused the system to exhibit crappy memory Write performance. I went through every setting I could, even going so far as to disabling SBGPP, but even that didn't help :\

 

 

 

Anyways, I did manage to get some benchmarks ran to illustrate the difference in performance, so I'll plug that system's HDD into a USB adapter to grab them.

 

If anyone has any thoughts on which pin to short to trick a recovery, and perhaps WHEN to short it, here is the pinout:

attachment.php?attachmentid=1139&stc=1&d=1328254478

Link to comment
Share on other sites

ALRIGHT! We're back in action thanks to a thread Stasio linked me to :D Holding the power when turning it on so that it'll then turn right back off in 4 seconds, then powering it back on, will trigger the second BIOS to engage :) (After it shut off I left the power button held in for a few more seconds just to make sure)

 

 

 

BTW there is no CPu-NB multiplier setting for llano i believe, do you see it in the asrock board? i looked through manuals for asus and they don't have a setting for the cpu nb frequency either.

 

There is not a multiplier, but it's a speed on that board. It is only selectable up to a certain MHz at a specifc memory speed. So at 1333 for example it'd limit to 720Mhz (which the Gigabyte runs at under DDR3-1866!), and at 1866 it runs at ~900MHz ;) I've got screenshots (which are in my review I linked to earlier), but it's almost 2:30AM, so I need to get to sleep. I'll post up a bunch of stuff tomorrow.

Link to comment
Share on other sites

I believe there is a setting for nb in the F3 bios, which makes me think it maybe hidden in later bioses.

 

It is Hidden, but it still doesn't work after restoring it :( That's what I mentioned having already done by restoring it in F7 (which PM me if anyone wants that, not that it seems to function).

 

I'll try rolling back to F3 and see if it's able to control the CPU-NB. Fingers crossed, because I don't like having one of the best boards and not having such a key option/setting to change... :(

 

 

Going to gather screenshots, I'll post them in a separate reply.

Link to comment
Share on other sites

attachment.php?attachmentid=1152&d=1328556275

A55 Pro3 - AIDA64-3850@3.58+NB@1107+DDR3-2300.png

This is the best, stable results with that board. It's only a 3+1+1 phase config by the looks of it, which after having the GB board my suspicions that it was limiting the overclocks is confirmed. I can bench the 3850 at 3.9GHz and DDR3-2445, nothing that ASRock A55 board could ever dream of doing.

 

----

attachment.php?attachmentid=1153&d=1328556275

AIDA64-3850@3.8+NB@943+DDR3-2445.png

Memory score for the Gigabyte, the best I've been able to manage so far. Quite good, but it's Write performance sucks, which again, is inline with what I experienced on the ASRock board when I
disabled
the ASMedia SATA-III controller
:confused:
. Not sure why that would occur, but it was consistent, and even then the Write was about 700+MB/s faster than this (fastest) Gigabyte result :\

 

----

attachment.php?attachmentid=1155&d=1328556275

AIDA64-3870K@3.0+NB@720+DDR3-1866.png

Defaults on the 3870K in the Gigabyte using the timings I've been using as "default". This is using the foolishly low CPU-NB speed of 720MHz, which doesn't help performance as you can see...

 

----

attachment.php?attachmentid=1154&d=1328556275

AIDA64-3870K@3.0+NB@720+DDR3-1866 6-8-6-34 CR2.png

Defaults on the 3870K in the Gigabyte, lower timings (forgot to adjust the Command Rate and tRAS lower) and crappier than expected performance

 

----

attachment.php?attachmentid=1156&d=1328556275

AIDA64-3850@2.9+NB@900-DDR3-1866.png

3850 on the ASRock, as you can see, Write performing
much
better at defaults with NB@900 than the Gigabyte does at any NB and DDR3 speed combination
:S

 

----

On all the AIDA64 compilation results you can see that the board doesn't much effect any of the benchmarks which have to deal with just the CPU, which some are only impacted by CPU speed, and so the higher NB or DDR3 speed doesn't make a difference.

Edited by Formula350
Link to comment
Share on other sites

attachment.php?attachmentid=1157&stc=1&d=1328560413

 

attachment.php?attachmentid=1159&stc=1&d=1328560413attachment.php?attachmentid=1160&stc=1&d=1328560413

Random Cache-Mem results of the 3870K on the Gigabyte. The second one is the mate to the previous post's 1866 6-8-6 results.

 

--------

attachment.php?attachmentid=1161&stc=1&d=1328560413

3.9ghz cachemem.png

Results on the Giga with 3870K@3.9GHz, which I dropped the DDR speed down to in turn lower the CPU-NB (which sadly I have no choice over) to rule them out. Interestingly, despite those drops the Write performance isn't as bad as expected.
:rolleyes:

 

 

 

Couple more left, YAY 5 pics-per-post! :banana:

Link to comment
Share on other sites

Last post of images for now, unless someone has any requests.

 

 

(long pics, sorry, had to combine 2 into one)

attachment.php?attachmentid=1162&stc=1&d=1328567658

MaxxPi2 Pro (internal beta) "Memory" bandwidth scores, highlighting again the vast difference in memory performance between the two boards. This time I went and configured the Gigabyte to the same settings as the ASRock. The only thing different (from what I can change) is that the Gigabyte has IMC Ohm, Drive Strengths and Drive Timing options, which I leave at Auto.

 

---------

attachment.php?attachmentid=1163&stc=1&d=1328567658

MaxxPi2 Pro "Overall" memory score, same as above.

 

---------

attachment.php?attachmentid=1164&stc=1&d=1328567658

Best Sandra I achieved with the ASRock, and at the same (stable) speeds as the above (3.58GHz, DDR3-2300). I've yet to reinstall it to run on the 3870K (went all screwy, won't run) while overclocked, but the default config only net like 16GB/s on the Gigabyte
:(

 

---------

attachment.php?attachmentid=1165&stc=1&d=1328567658

Sandra, again, but just outlining the change in performance on the ASRock board between the default NB speed of 900MHz when you set DDR3-1866(which I listed as it's rated 1800MHz) and the 742MHz (1500MHz) that the system selects at 1333. Also is the 2300Mhz which results in 1112MHz (2224MHz). This was before having done the subtiming tweaks in the above results.

 

---------

attachment.php?attachmentid=1167&stc=1&d=1328568543

ASRock's BIOS showing the option for CPU-NB speed options. It's a drop down listing a whole bunch, but no screenshot of that, sorry.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...