Jump to content
HWBOT Community Forums

Recommended Posts

Download latest: https://sourceforge.net/projects/hwbotaquamark3/files/latest/download?source=files

 

Changelog:

 

2.55.110

[NEW] A copy of the screenshot integrated into scorefile is stored in installation folder.

[FIX] Crash when opening 'Compare Online' without Internet connection.

[FIX] Default screenshot format is PNG 50% as JPG is not working under Windows XP.

[uPD] Increased range of screenshot quality from 30-100 to 0-100.

[uPD] System Info Library updated to v1.10, with the following changes:

--New Drivers: Cat 13.12 WHQL/WU

 

2.54.109

[FIX] Log files were not written to disk.

[NEW] Added support for Window Themes.

[NEW] Added 'Compare Online' feature.

[NEW] Added settings for Screenshot format (PNG/JPG) and quality (30 to 100), to prevent huge scorefiles.

[uPD] GUI adjusments for 125% DPI.

[uPD] Qt Framework updated from 5.1.1 to 5.2.

[uPD] Settings are saved each time they are changed rather than waiting to press START.

[uPD] System Info Library updated to v1.09, with the following changes:

--Added detection for AVEXIR Core 2400, Team Xtreme Vulcan 1600

--New GPUs: GMA X4500, GMA 4500MHD, GMA 4500, GMA 500 Mobile, GMA 900 Mobile, GMA 900, MARS II

--Updated GPU-Z to v0.7.5

 

2.53.108

[FIX] Menus 'Forums' and 'Clear Aq3 Logs' now work.

[uPD] Minor GUI changes and fixes.

[uPD] Separated benchmark specific code from GUI code and further optimized for speed and memory usage.

[uPD] Certains brands are renamed when saving the scorefile to match with HWBOT's database.

[uPD] System Info Library updated to v1.08, with the following changes:

--Improved detection of RAM Vendor & P/N

--New Drivers: Cat13.11 WHQ/Beta9.4/Beta9.5

--New GPUs: MSI 7970 Reference / TwinFrozrIII / Lightning

--Improved CPU Socket detection

--New SKUs: Toshiba Satellite P755-11T, HP Envy 6-1076ez

--Renamed CardExpert Technology to Gainward, BFT Tech to BFG, Palit Microsystems to Palit

 

2.52.107

[FIX] LOD did not work on all systems.

[FIX] Video Card icon did not display properly..

[FIX] Windows XP '0 score' and AUTO mode.

[NEW] Changed the installer from AHK to NSIS in order to avoid false positives from AV software.

[NEW] Added menus.

[NEW] Added shortcuts: F7 (Save to Desktop) and Ctrl+S (Start Benchmark).

[uPD] Additional security checks (Thanks BarboNet)

[uPD] Code cleanup and optimizing.

[uPD] System Info Library updated to v1.07, with the following changes:

--Sony Corporation is renamed to SONY

--Empty RAM slots are skipped when reading RAM P/N, Cfg Speed, Rated Speed

--Improved RAM Vendor codes list

--EDO DIMM was renamed to EDO

--OS ServicePack detection routine disabled on W8/8.1

--Some strings will be trimmed under VMWare Player and VirtualPC/XPMode

--New video cards: HD5970

 

KNOWN ISSUES

*Startup is slowed down by dxdiag.

*WinXP: benchmark doesn't go full screen and is Not Responding if a Windows Explorer window is opened.

*WinXP: GFX driver detection fails

 

2.51.106

[FIX] Missing dll libraries from installer package.

[FIX] Some icons were not displayed on NVIDIA systems.

[FIX] Registry setting background did not work properly.

[REM] Default background 'circuits' was removed to keep a cleaner look and smaller exe size.

[uPD] If LODAdj is not found, it will assume it is not an ATI/AMD card.

[uPD] System Info Library updated to v1.06, with the following changes:

--Code cleanup and fixing that prevented the application from running on some systems were expected information was missing.

--Empty RAM slots are skipped when reading Vendor name.

--Detection mechanism of NVIDIA Display INF file changed

--New BIOS Vendors: Phoenix, Award, InsydeH2O

--Detection of DirectX version

--Detection of GFX used output ports (VGA/DVI/HDMI etc.)

--New Drivers: Cat13.11 B9.2

--Completed Radeon R9 series.

 

KNOWN ISSUES

*Startup is slowed down by dxdiag.

 

2.50.105

[NEW] Complete rewrite in Qt5/C++

[NEW] 'About' page with proper credits and a changelog.

[uPD] Settings now include a couple more features that were previously unavailable or not user changeable.

[uPD] System Info Library updated to v1.05, with the following changes:

--Got rid of WMI dependency

--Ram Information: vendor, module count, rated/configured speeds, p/n, total capacity, maximum capacity

--Processor Information: vendor, name, family, freq, bus, count, active threads, socket/package, max freq

--Bios Information: version, revision, build date, firmware revision, vendor

--Motherboard Informaion: vendor, name (based on sku for notebooks), revision, s/n, socket count

--Hewlett-Packard Portable SKUs countrification

--New SKUs: HP Folio 13-1050ez, HP ProBook 430 G1, HP Spectre XP Pro (various), HP ProBook 4340s, HP ProBook 4740s (various), HP Envy d7 (various), HP Envy 17 (various), HP EliteBook 8770 (various)

--New CPUs: QX9770, i7 995X, i7 ###QM, FX-9590 ES

--New RAM vendors: Walton Chaintech, Ramaxel, G.Skill, KINGMAX, Princeton, GeIL, Nanya, Crucial, Patriot, Qimonda, Swissbit, Corsair, Elpida, TeamGroup, OCZ, A-DATA, Kingston, Itec Memory, WINTEC, Super PC Memory, GoldenRAM, DATARAM, Smart Modular, Transcend, Micron, Mosel Vitelic, Samsung, Infineon, NEC, AMD, Xerox, Apple, HP, SK Hynix, Mushkin, ASint, Winbond.

--New GPUs: Radeon R7 Series, Radeon R9 Series

--New Drivers: Cat13.2/13.3 BETA detection fix, Cat13.9 WHQL, Cat13.10 B2, Cat13.11 B1/3/6/7, All NVIDIA drivers (generic), couple Intel GMA/HD/Iris from branches 6/8/9.

 

2.27.104

[uPD] Main GUI will no longer display CPU speed.

[uPD] System Info Library updated to v1.04, with the following changes:

--Code cleanup

--Detection for Catalyst 13.10 BETA

 

2.27.103

[FIX] Temporarily removed detected CPU frequency from scorefile, to avoid website parsing error.

 

2.26.102

[uPD] Application versioning will include smaller increments for SI library updates.

[uPD] System Info Library updated to v1.02, with the following changes:

--Extensive Subvendor list for VGA

--Can read VRAM quantity

--Added couple more ATI/AMD cards (mostly HD7/8 series)

--Intel BIOS versions are shortened to display only relevant info

--Fixed code errors that prevented race conditions to work

--Can display ATI/AMD driver friendly name and differentiate BETA versions

(GPU-Z can't tell if it's beta or WHQL) from 11.11 up to 13.8B2

 

2.26.000

[FIX] Improved security.

[FIX] Logo's alpha channel didn't work on older cards displaying a black background.

[FIX] Save and Open CPUZ/GPUZ buttons will not be shown if benchmark was aborted.

[ADD] Basic system info displayed into main window. (WMI service must be ON).

[ADD] User can select benchmark settings between Manual and Auto. Use manual for old cards/IGP.

[ADD] Multiple cores affinity (artificially limited up to 8 threads for now).

[ADD] Norwegian translation (Thanks Maximous)

[uPD] GUI Redesigned to allow more information and future skins.

[uPD] Installer will let you install on 98/ME but there is no guarantee it will work.

[uPD] Improved translations in RO/IT/FR (Thanks Christian Ney)

[REM] VC Redis will no longer be installed on 6.x systems as it's not needed.

[REM] Removed 'Submit online' button until it works better.

 

2.25.000

[FIX] Score was not saved on some stripped Windows XP systems.

[FIX] Error Exception if WMI is not enabled on your system.

[uPD] Installer contains the VC++ 2008 v9.0 x86/x64 redis.

 

2.24.000

[ADD] You can now select 'All Cores' for process affinity.

[ADD] F1 hotkey for a quick Debug Message.

[ADD] F7 hotkey for a quicksave on desktop. It will not check for CPUZ/GPUZ!

[uPD] Changed icon to original Aquamark green icon.

[uPD] Updated RO translation.

[REM] Results are saved directly on desktop instead of 'Aquamark Results' folder.

 

2.23.000

[FIX] Datafile was not saved if the videocard name contained illegal character (Thanks mtech)

[uPD] Completed Persian/Farsi translation (Thanks Olesius)

 

2.22.000

[FIX] Memory Tab was not opened in CPU-Z OC version. (Thanks topdog)

[ADD] Partial Persian/Farsi translation. (Thanks Olesius)

[ADD] Hover mouse icon for HWBOT logo.

[uPD] TRISCORE is displayed using a bigger font size.

 

2.21.000

[FIX] Button 'STEP1' is not shown if benchmark was aborted using ESC key.

[FIX] Main GUI did not load after benchmark closed.

[REM] Removed the 'Check for updates' button because feature is not implemented yet.

 

2.20.000

[FIX] Stuck in a loop when trying to detect CPUZ.

[FIX] Uninstaller deletes registry keys left in Wow6432Node.

[ADD] Pressing ESC during benchmark will quit instead of abort.

 

2.19.000

[FIX] STEP1 button no longer worked if there was an error in CPUZ detection.

[FIX] When manually browsing for GPUZ the filter is *.exe instead of gpuz.exe

[ADD] Spanish Translation (Thanks Sweet)

[uPD] Improved startup dialog.

[uPD] Can detect custom CPUZ versions (ROG/G1/OC)

 

2.18.000

[FIX] On Windows 7 with Classic Theme applied the screen couldn't be captured for SS.

[FIX] Duplicate score files are renamed instead of being overwritten.

[FIX] The main GUI no longer starts with its titlebar underneath Windows taskbar.

[FIX] Smarter window arrangement.

[FIX] Minor GUI changes to improve i18n for both Wrapper and installer.

[FIX] Wrapper will check if aquamark executable exists before trying to open it.

[uPD] Exception Catch for the 'Submit' button and Logo click.

[uPD] Romanian translation updated.

[ADD] Dutch translation (Thanks Massman)

[ADD] Will check for local CPU-Z/GPU-Z.

[REM] CPU-Z and GPU-Z are no longer bundled with the wrapper installer.

[REM] CPU-Z is no longer used to read CPU/RAM/Motherboard info due licensing issues.

[REM] Keyboard/Mouse input is no longer blocked during STEP1.

 

2.17.000

[FIX] Score swap fixed.

[FIX] Installer is a little more compact.

[ADD] Italian Translation (Thanks Christian Ney).

[ADD] German Translation (Thanks der8auer).

[uPD] New logo and minor GUI changes.

[uPD] aquamark.exe renamed to aquamark3.exe to avoid graphic driver app specific tweaks.

 

2.16.000

[FIX] Added a new HWBOT logo as Massman suggested.

[FIX] Save/Submit buttons only appear after pressing the previous button(s) to avoid empty scores.

[uPD] i18n support based on Windows language. User can't manually change it.

 

2.08.000

[FIX] Fixed the archiving process.

[FIX] Improved Win 8 support.

[FIX] Minor GUI fixes

[uPD] Supresses GPU-Z "Install" option automatically

[uPD] Uninstaller selfdeletes

[uPD] Removed the HASH check of the 2 dll's

[uPD] Inputbox sets default affinity to last core

Edited by GENiEBEN

Share this post


Link to post
Share on other sites

* Some antivirus software will detect versions prior 2.52 as false positives. Please refer to the links below to understand why.

An open letter for Antiviral software companies

Malwarebytes Ticket

 

* SmartScreen filter issues

Here are answers to some common questions about Internet Explorer* SmartScreen Filter.

HTG Explains: How the SmartScreen Filter Works in Windows 8

Edited by GENiEBEN

Share this post


Link to post
Share on other sites
Main download page still has 2.22, for some reason Microsoft SmartScreen filter blocks your link above as unsafe.

 

Main page will not be updated as fast as the one here. Who uses SmartScreen?

 

You must not have children :P

 

:P At least XP does not have this 'useful' feature from M$

Edited by GENiEBEN

Share this post


Link to post
Share on other sites

Finally had some time to work on this today, hopefully it's done by Monday.

aqua3_226_maingui.png

aqua3_226_settings.png

 

Manual mode will launch Aquamark just like the old wrapper, this way solving the issues introduced by Auto mode when using IGPs.

The thread affinity only works up to 8 for now, for values above I will need testers since the API does not simply allow you to specify a core number :)

Edited by GENiEBEN

Share this post


Link to post
Share on other sites
Nice work thanks.

 

Now find a way to fix the cpu perf bug :D

 

Actually with this version it should score higher in CPU test because the old affinity did not work as I expected it would, should now be fixed. Also now that you can select more cores, there's a huge boost with some cpu's.

 

Let me know if there are other feature requests that I might be able to push in this build.

Share this post


Link to post
Share on other sites

I was reffering to the cpu score bug we were talking about last time. When changing vga or driver on the same setup the cpu score becomes 4x lower.

Share this post


Link to post
Share on other sites
Actually with this version it should score higher in CPU test because the old affinity did not work as I expected it would, should now be fixed. Also now that you can select more cores, there's a huge boost with some cpu's.

 

Let me know if there are other feature requests that I might be able to push in this build.

 

Great job Genieben :) , so the old wrapper was giving bugged slow scores then due to old affinity implementation not working correctly. Thank you so much for the fix , will test asap :celebration:.

Share this post


Link to post
Share on other sites

2.50 alpha

 

Started porting the application to Qt5/C++, about 40% done by now.

aqua3_250alpha_settings.png

Share this post


Link to post
Share on other sites

Hello i try the last Version 2.53.108 but it not work...

My system was phenom ii x4 am2nf3-vsta and sapphire 4650 agp...

My system is xp with sp3 and net Framework 2.0 sp2, 3.0 sp2 and 3.5 sp1 toghether with visual c++ 2008 and 2010

Thanks For support

Share this post


Link to post
Share on other sites

There is no .NET requirement for 2.5x versions! Only install everything that comes with the installer.

Share this post


Link to post
Share on other sites
There is no .NET requirement for 2.5x versions! Only install everything that comes with the installer.

 

Net Framework 4.0 is necessary on winxp sp3, if is not present the last aquamark gui doesn't work.

Share this post


Link to post
Share on other sites
Net Framework 4.0 is necessary on winxp sp3, if is not present the last aquamark gui doesn't work.

 

The application has absolutely NO connection with .NET environment, it was done with Qt Framework for exactly this reason.

Share this post


Link to post
Share on other sites
The application has absolutely NO connection with .NET environment, it was done with Qt Framework for exactly this reason.

 

Uhmmm it's so strange.... Because without net Framework it doesn't work on My system....

I try later to run it on a new Windows installation and on win98se or Windows 2000 sp4 :)

Thanks For this information... This means that i can finally run with old agp\pci cards with win98se (like rage pro 8mb) :D

Edited by Stermy57

Share this post


Link to post
Share on other sites

You can not run it on Win98SE. This is due both Qt Framework and OpenSSL 3rd-parties. I'm not sure about W2K.

 

For cards that can't be run on W2K/XP, run it without wrapper and save a normal screenshot with cpu-z/gpu-z windows. I will see what can be done to upload those.

Edited by GENiEBEN

Share this post


Link to post
Share on other sites
You can not run it on Win98SE. This is due both Qt Framework and OpenSSL 3rd-parties. I'm not sure about W2K.

 

For cards that can't be run on W2K/XP, run it without wrapper and save a normal screenshot with cpu-z/gpu-z windows. I will see what can be done to upload those.

 

Uhm understand...

I Will test it on w2k on the weekend!

So which Version i can use with old cards?

Thanks For support :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×