Jump to content
HWBOT Community Forums

Z77 FTW + HD 7970 hangs


Recommended Posts

Something weird with my setup.

Z77 FTW works ok with e.g. GTX 580. But when I put one of my HD 7970 there is no image at all. 7970 cards work ok with another boards.


When I put GTX 580 and change "Fast PEG Initalization" to "off" and then switch card to HD 7970 I got an image, but board always hangs during booting and nothing can be done.

I also tried switching PCIe to GEN 2.0 and disabling Intel GMA, but it didn't make a difference.


I checked all official BIOSes: 1.10, 1.12, 1.17, 1.21 and 1.22 - still the same issue.

I am struggling with this for hours... I guess it is something with PCIe settings, but I have no idea what to change apart what I already changed.

Edited by ivanov
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...