Jump to content
HWBOT Community Forums

Asus Strix X670E E Gaming + 7950X + G.skill Neo - No Boot = Lock on boot logo.


Recommended Posts


Hi ,


I have a brand new : Asus Strix X670E E Gaming + AMD 7950X + G.skill Neo 6000 CL30 + Seasonic Prime 1300

I assembled them on the table to give them a key to see that everything is working properly.  However, i only get the boot logo and it doesn't go past it, but it doesn't let me enter the bios either ( like in video) . I mention that it doesn't get stuck, I can turn the caps lock light on and off, and if I press ctrl+alt+del I restart the system.

I tried with 3 different types of keyboards in different USB ports, with a dedicated and integrated video card. With 1 or 2 memories in different slots, with and without ssd on 2.5" sata or m2 nvme.

I tried bios flashback with and without cpu/ram, everything worked normally... and you still get to the boot logo.

Any idea what it could be?




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...