Jump to content
HWBOT Community Forums

R9 290x lightning LE


Recommended Posts

Hello. I have problem with this card, on card itself is lightning LE but according to Gpu-z bios is normal lightning because gpu clock shows 1080 Mhz and LE should have 1030 Mhz. if i run benchmark Pci-e shows that support pcie 3.0 x16 but card is running on pcie 1.1 x16. and gpu clock jump from 300Mhz (idle) to 576 Mhz which is weird. if i switch to Ln2 bios, gpu-z shows that gpu clock is 1000Mhz (which should be ok according to review of normal lightning) and if i run benchmark gpu clock jump to 1000mhz which is correct, but pcie shows pcie 3.0 x8.  but card looks ok so i don't know why PCie act weird. And if LN2 bios clock work ok i think that standart bios might be broken so i would like to Flash it, but i can't find Bios for LE version only original Lightning so i don't know if i should try to flash it. Only LE bios i found is some unverified on TPU https://www.techpowerup.com/vgabios/166010/166010  


Any idea? Thank you 

Edited by Rimmer
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...