Jump to content
HWBOT Community Forums

Rampage VI Extreme iROG2 update issue!


Recommended Posts

i have a very strange problem :o


I had bios 0018 on bios chip1 and bios 3602 on bios chip2.

tried to flash bios chip2(3602) with 0020.CAP to test my 4960X

bios flashed ok as also irog 1, but i rog2 is updating forever and never completes and is looping again and again.


I flashbacked many bios.cap (R4E.CAP) with bios 1 or 2 but i get the same error everytime tries to update irog2 firmware, updating forever very slow


also flashbacked to bios.rom with use of ERALL.ROM ...nothing again, i don't know what else to do!


Any ideas guys?

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...