Jump to content
HWBOT Community Forums
Lio40

Ryzen on Win7 Win10

Recommended Posts

Can someone help me with my new Am4 System?

 

My System:

Ryzen 7 1800x

Asus Crosshair VI Hero

G.Skill Trident Z

1200Watt PSU

and a bunch of GPU`s i wana bench

 

First it all workt out perfect. Installing CPU, MOBO, RAM and all was no Problem.

I installed Win 10 Home Premium,

updated BIOS on the Crosshair to 5704,

benchd some 2d Benches and uploadet them

 

then i got 10 E-mails (one of your submissions has been blocked) Win 10 not allowed with AMD Ryzen

 

I was pretty pissed. But ok thats the Rules.

 

The next Day i tried installing Win 7. And its pretty much impossible.

 

USB does not work on Win7 so Keyboard and mouse do not work. (i tried all USB 3.0 and 2.0 Ports)

Asus Crosshair does not have any PS2 Port, so i installed Win 7 on a different System. and tried to boot with Ryzen. And what should i say... it doas Not work.

 

I have seen the guide on anandtech

 

How To Get Ryzen Working on Windows 7 x64

 

but it seems to be almost impossible to use the new AMD CPU`s on HWBOT (wich i have been waiting for Years)

 

 

I think there are a Lot of Submissions wich have been blocked and i really think there must be an easier way for AMD user to be compatible on HWBOT.

 

(btw sry 4 bad english)

Share this post


Link to post
Share on other sites

Ok i try this. But there must be a better solution. What should all the other "team red" guis do?

Share this post


Link to post
Share on other sites

No other solution for installing Windows 7. Drivers need to be slipstreamed.

A good idea would be to slipstream the drivers, then share your ISO file with your team members.

Share this post


Link to post
Share on other sites

And no one thinks about giving every one the same chances to participate at HWBOT?

Share this post


Link to post
Share on other sites

I was also thinking of providing a slipstreamed Win7 x64, but I'm currently having a problem with it on B350 motherboard, while it installed fine on Crosshair VI. Don't really know what is the problem, but if (when) I manage to solve it, I could share it on hwbot.

Share this post


Link to post
Share on other sites

May be http://dlcdnet.asus.com/pub/ASUS/misc/utils/ASUS_EZInstaller_V10310.zip will work for you also.

It creates a win7 install medium (dvd iso or USB stick) with usb3.0 and ahci drivers included from your win7 install dvd. Install on NVMe M2 media is supported also(optional).

A pdf with step-by-step instructions is included.

I will install it on the weekend on my new system:

 

Ryzen 7 1700X

32 GB RAM( 2x16GB) Corsair CMK32GX4M2B3000C15

Asus Prime X370 pro

Samsung 960 Evo M.2 500GB

Share this post


Link to post
Share on other sites

I'm planning on installing Windows 7 and all the updates using a A88X board, installing the C6H drivers, then booting the Win 7 drive on the C6H. Microsoft also said that they were going to actively block updates for modern CPUs on Win 7. In any case, a giant PITA.

Share this post


Link to post
Share on other sites
Microsoft also said that they were going to actively block updates for modern CPUs on Win 7.
Yesterday I got all updates for a new installed win7(sp1).
In any case, a giant PITA.
If it looks like a duck, swims like a duck, and quacks like a duck, then it probably is a duck.

 

Installation runs like a charm from a usb 3.0 stick created with: http://dlcdnet.asus.com/pub/ASUS/mis...ler_V10310.zip

Beware the choice of the correct usb device if you have more then one connected. The tool has overwritten the MBR of my external 4TB backup harddisk. :mad: Now all data rescued with testdisk tool. :ws:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×