Jump to content
HWBOT Community Forums

Recommended Posts

(narrative)

This card has threads all over the net about its inability to work at factory Boost speeds....or even factory base clock. Apparently the first batch are the worst and they can be identified by the lack of backplate.

I picked up one of these and got stuck into figuring out why they suck (sorry, eVGA)

A lot of comments online pointed towards the HDMI firmware and i'm certain that a % of people fixed their problem using the HDMI firmware patch from nVidia.

The MHz issues are real, though. Online comments talking about hacking the MHz away until the card is running nVidia's basic profile of 1126MHz. The finger was pointed at the eVGA Boost table.

I spent a lot of time reducing MHz and having the same blackscreen issue usually very soon after load was applied, regardless of MHz. nVidia's debug mode really really helped and with it enabled, the problem was gone... but at 1075MHz, the GTX980 is being outperformed by a healthy GTX970.

Strangely, applying debug MHz in a BIOS flash didn't give me stability.

eVGA used their own PCB design for the FTW card and after thinking about the problem in a different way and thinking about the PCB squeal that was audible before blackscreen, I tried reducing the voltage.

BINGO!

The eVGA PCB design is messed up and can't handle voltage+load, even though the TDP doesn't get anywhere near 100%. There might be a hardware fix (mllrkllr? Buildzoid? ....Tin?) but I can't see it being pretty.

With the vCore reduced to 1.05v, the card can run towards 1300MHz with no problems...and really nice temperatures. Anyone putting together a modded BIOS should look at the fan profile too. eVGA missed the sweetspot there as well.

 

The MHz are lower than the 1380MHz Boost that eVGA promise...yes... but the card works and that's better than nothing. Higher MHz are off-limits because they need a voltage that the card straight up can't handle.

 

BIOS attached. It's for the FTW card only (any compatibility with other cards is co-incidental and I guarantee nothing) The HDMI fix HASN'T been baked in. MIght get around to that.

 

Flash at your own risk. If unsure of the steps involved, please ask for advice or don't do it.

 

Card boosts to a very solid 1265MHz (bit of breathing space for different ASIC quality) and the RAM is set to 1850MHz (again, breathing space) Fan is set to 20% idle, moving up to 30% at 44 Celcius. vCore set to 1.05v for all Boost states.

eVGA GTX980FTW K404 MHz and fan fix.rom

Edited by K404
  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...