Jump to content
HWBOT Community Forums
Queen_Fiona

Unable to install on Windows 10 Z77 Sandy Bridge, OC driver error "the installation failed because a function driver was not specified"

Recommended Posts

For whatever reason, my current keyboard will only work to enter the BIOS on a fresh boot...and only some of the time. If I reboot to enter the BIOS, I can't press any keys and therefore can't, making any kind of overclocking extremely inconvenient.

 

Naturally, I want to install Intel XTU. I used it on my previous machine (actually just a different motherboard), and it worked fairly well, but it's completely failing me now. My current configuration is an i7-2600K, installed in a D77GA-70K, running Windows 10 Pro. This is one of Intel's own boards, from their Extreme product line, so it seems strange that XTU would have issues here.

 

I attempted to install the latest version, without success. I could change the power limits, but nothing else. I tried manually installing the drivers in the folder, which changed nothing. I tried installing multiple older versions from your library and manually poking at their drivers, none of which worked - even the ones specifically marked as compatible with Sandy Bridge.

 

The only clue I have is the error message given when I try to install the driver I believe is the culprit: iocbios2.sys, or the "Intel® Overclocking Device Driver". Every other driver or prerequisite seems to install okay, even if I have to force it, but that one fails every time. Using the in-folder installer and the INF both say they succeed even though they don't.

 

My last resort, which was trying to add the OC driver manually to Device Manager results in this cryptic error, which appears to be some sort of stock fallback that's been in NT-based Windows for ages: "The installation failed because a function driver was not specified." This is clear as mud, and Google wasn't much help - it seems to cover for all kinds of issues that don't seem to have much with the error itself.

 

I hope this is enough information! If anyone has any ideas what might be happening, let me know.

Share this post


Link to post
Share on other sites

Some quick guesses here.

 

1) Keyboard: is num lock enabled? If not, it's possible your keyboard is not supported by UEFI. Keyboard/mouse compatibility is more problematic that most people think. Try another one, possibly using another USB port.

 

2) XTU: probably related to the version you're using. Officially Intel only supports the latest three platforms in XTU. Sandy Bridge is hence not supported anymore. In @xxbassplayerxx's version library you can find v5.2.0.14 which is both compatible with Sandy Bridge and can still verify the scores online.

Share this post


Link to post
Share on other sites

Keyboard isn't really something I expected to be solved here. I might have something I can drag out if I find it, but that keyboard always had problems due to wireless reception issues and only worked sporadically on my last mobo for BIOS. That's not really relevant - in-OS adjustment will always be a hell of a lot more convenient.

 

Also, as indicated, I tried several versions. v5.2.0.14 was one of them. I tried the latest v6.1.2.13, v6.0.2.8, and v4.2.0.8 (marked as SB compatible) as well, most of them from the version library. They all installed fine as an application and the benchmarks (and power limits, for some reason?) and everything work alright, it's just the drivers that would allow me to OC that seem to be the issue. In fact, there seemed to be little difference at all between the four versions, so it's probably just the driver installation problem.

 

I did find a thread about a similar driver issue in the v6 series, but it was marked as fixed in the latest version (or close to it). Nothing seemed to help much. I've pulled 4.4 GHz out of stock voltage so far, which is encouraging me to go further!

Share this post


Link to post
Share on other sites

I didn't know that, so then 6.1.2.13 doesn't officially support IB?

Haswell, Broadwell and Skylake are last 3, I get approx the same BM results and all seems to work as 5.2 version.

 

I mainly installed 6.1 for better Win10 support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×