Jump to content
HWBOT Community Forums

Gpupi for cpu: How to set up?


Recommended Posts

Hi folks!

Am SO frustrated!!! :( I just cannot seem to get this darn thing running. Have tried with both existing as well as sparkling clean builds but keep getting a variety of issues so haven't been able to run this for ages on any platform. 

Is there a step by step guide? From what I gather, the new intel version of opencl is the most efficient. That said, which darn file(s) do I need? 

Atm, trying to get it working for z97 but have the same problems on every platform I've tried. 

What the heck??


Link to comment
Share on other sites

What are the problems you are refering to? Without a detailed description it's difficult to help.

As for step by step for Intel CPUs:

  1. Download the latest Intel OpenCL runtime: https://registrationcenter.intel.com/en/forms/?productid=3207
  2. Open GPUPI, "Calculate", select your CPU in the latest Intel OpenCL platform you can find in the settings dialog and run.

There could be inconveniences regarding your OS timer, where GPUPI states that you can't submit due to possible timer skews. Either enable HPET (GPUPI 3.3 will give you that opportunity by just pressing a button) or run Windows 7 or Windows 10 prior to RS5.

Link to comment
Share on other sites

Thanks mat!

At launch, I always get the following error:
Name:  gpupierror1.jpg Views: 56 Size:  338.2 KB

Googled around and found that "the fix" is to copy the opencl.dll files from the amd folders to the system32 and syswow64 folders. That gets gpupi working but my times are horrendous (like 30 places lower than where the chip should score). Take a look at this screenie....cpu is at 6.7GHz, notice there's no opencl version message at the top of the gpupi window and hwinfo failed (I know it's not needed but it's another, likely related issue).

Tried on a clean 7x64 build with an nvidia card, installed the intel opencl for visual studio, various c++ but then gpupi wouldn't even open (can't recall that error atm, though). 

Actually got the app to start once but it threw an error when I tried to start the calculation. 

Not sure what the heck I'm doing wrong 

Link to comment
Share on other sites

On 3/18/2019 at 5:21 PM, bigblock990 said:

This error is because your opencl doesn't support opencl 2.0

You need to install amd sdk v3.0+ or intel 18.1

Gpupi 3.2 legacy will work with opencl 1.2

This is normally the solution.

As far as I can see on your screenshots you are not installing the AMD OpenCL SDK 2.9.1 or 3.0, but an old legacy AMD display driver. Try this download: https://www.softpedia.com/get/Programming/SDK-DDK/ATI-Stream-SDK.shtml

Link to comment
Share on other sites

  • Members
47 minutes ago, funsoul said:

Thanks! Finally got it running using the intel 18.1 file on z270/7x64. Now to figure out why my result times are about 50% higher than they should be based on cpu speed and ram timings. 

Make sure you're comparing against others using the new intel open CL. Basically wiped out any old results

Link to comment
Share on other sites

  • 1 month later...

Got some issues... got error vcruntime140.dll missing.... somehow i mannaged to run gpupi but after restart i could not boot anymore... disk error. i forced a repair on win7 now i can boot but i get biocredprov.dll error + vcruntime140...

Link to comment
Share on other sites

vcruntime140.dll is the Visual C++ 2015 runtime, necessary to run all executable made with Visual Studio 2015 and C++. You can download it here:


Select the 64 bit version (x64) for the default benchmark. 32 bit (x86) is needed for  32 bit executables, for example GPUPI's legacy version. But that should only be used for Windows XP and very old GPUs/CPUs.

biocredprov.dll is an OS issue that has nothing to do with GPUPI.

Edited by _mat_
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...