Jump to content
HWBOT Community Forums

Intel opencl versions and performance in GPUPI 3.2

Guest TonyBombassolo

Recommended Posts

Guest TonyBombassolo

I did some software re-installs on my machine recently and found a small oddity with the Intel Open CL versions and the GPUPI 3.2 1b benchmark for CPU.

If you run GPIPU 3.2 with the Intel OpenCL 3.0 executable (for me, it failed every single time after step 4), even though I knew my rig was stable and had run this benchmark before, so I checked my screenshots of the past, to verify settings.

When I looked at the actual GPUPI 3.2 executable in my failed runs, it showed 

Allocated Device Memory: 80mb

When I looked at the successful runs I had done in the past, it showed 

Allocated Device Memory 335.56mb

At this point I noticed I had OpenCl 3.0 from 2022 instead of the Intel OpenCL 2.1 I had in my previous runs. 

So if you are running into repeated failures on GPUPI 3.2 1b for CPU, verify you have the correct OpenCL for Intel processors (unless you are AMD ofc)

Once I uninstalled OpenCL 3.0 from 2022 and reinstalled from the opencl_runtime_18.1_x64_setup.msi installer, everything worked perfectly.

I did have to reinstall GPU driver though because Intel uninstall removes it from GPU driver too for some stupid reason.


Edited by TonyBombassolo
Link to comment
Share on other sites

  • Guest changed the title to Intel opencl versions and performance in GPUPI 3.2


I ran into same problem a while back.

there were so many versions floating around. Intel and AMD. I just tried another and it was fine so I moved on.

you’ll notice that all the best scores for a particular cpu will use the same runtime. Someone has done the work already, as well as finding the best batch size and reduction settings.

one runtime is not best for all cpu.

before you start subbing check what runtime the leaders are using, and the parameters, for your cpu.

newer =\ better

Edited by L0wpull
  • Thanks 1
Link to comment
Share on other sites

There are also different versions of the installer for open cl 2.1. one works fine and one gives error after loop 4. So make sure to use the one named 18.1, like example above. If it's named 2.1 it won't work, even though it should be the same version.

Edited by Rauf
  • Thanks 4
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...