Jump to content
HWBOT Community Forums

Windows 7 x64 SP1 with integrated drivers for Zen


Recommended Posts

You can try one of my tools.

ZenStates: https://zenstates.protonrom.com/

SMUDebugTool: https://github.com/irusanov/SMUDebugTool/releases

Due to the changes in firmware, you need to always set some values for the PBO limits. 0 was used as "auto" before, but it's now possible to set 0 as well. I'm not ready with the new version yet.

You can also use SMUDebugTool if you only need to change the multiplier in OS. You can do almost everything with it, but it's all manual. First tab allows to set the multiplier easily though. It had been tested by the top US guys and it works.

  • Thanks 1
Link to comment
Share on other sites

21 hours ago, I.nfraR.ed said:

You can try one of my tools.

ZenStates: https://zenstates.protonrom.com/

SMUDebugTool: https://github.com/irusanov/SMUDebugTool/releases

Due to the changes in firmware, you need to always set some values for the PBO limits. 0 was used as "auto" before, but it's now possible to set 0 as well. I'm not ready with the new version yet.

You can also use SMUDebugTool if you only need to change the multiplier in OS. You can do almost everything with it, but it's all manual. First tab allows to set the multiplier easily though. It had been tested by the top US guys and it works.

Thank u for your reply.

Both tools look interesting. But I would like to know more about the differences between them.

For example, you are mentioning that SMUDebugtool can change the Multi. But this is also what Zenstates can do, right?

And about the PBO, where should I set the PBO limits? Are u talking about the BIOS?

Link to comment
Share on other sites

  • 3 weeks later...

Hello, anyone have guide to setup Windows 7 for X570 + Zen2 (Ryzen 3rd Gen)?
Or kind-hearted enough to share the working Win7 installer ISOs / installation images (like Acronis .tib file) to restore to?
😃😀

I have Win7 image that work flawlessly with X370 / X470 MBs + Ryzen 2nd Gen, but isn't working properly in X570 + Zen2.
I can't have any USB working on this new platform. And sometimes it has booting issue. 😕

I had slipstreaming new USB3 driver to my Win 7 installer ISO but didn't work. And I heard this method already doesn't work anymore?!
And we must use / install another (modded?) USB3 driver after Win 7 installation? How? Can I get the stuff?

Thanks for helps.. ☺️😊

Link to comment
Share on other sites

  • 3 weeks later...
  • 7 months later...

I tried my Asus ch hero6 x370 OS w7 installation and it would bsod on my new Asrock taichi x570 lol , Tried many times to install w7 on Taichi x570 and 5600x cpu but no luck so far :( slip stream usb drivers using nlite but it does not work at all it will always bsod during installation of fresh w7.

Link to comment
Share on other sites

  • 1 month later...
  • 10 months later...
  • 1 month later...

@Leeghoofd
Thank you very much for this ISO; works absolutely great 🙂
Copied ISO-Content on USB-Stick (16GB/Fat32) and Voilà.

Installed a few Times, tested and still testing with:
Ryzen 7 5800X
MSI MAG X570 Tomahawk WIFI (BIOS 7C84v17)
32GB DDR4 (2x16GB) (G.Skill RipJaws V F4-4000C16D-32GVK)
Sapphire Radeon RX 580 & ASUS Geforce 210
Samsung 840 EVO (250GB/SATA)
Keyboard @ PS2 / Mouse @ USB2.0

Best Greetings

  • Thanks 1
Link to comment
Share on other sites

  • 4 months later...

I don't know what happened but it says: "A required CD/DVD drive device driver is missing. If you have a driver floppy disk, CD, DVD or USB flash drive, please insert it now

Note: If the Windows installation media is in the CD/DVD drive, you can safely remove it for this step."

I'm using a Lenovo IdeaPad 330S-15ARR with AMD Ryzen 5 2500U, 4GB RAM, 1TB HDD and AMD Radeon Vega 8. I think the issue is that the USB 3.0 Driver doesn't work properly. Not even NTLite detects the Driver. I don't have USB 2.0.

Hopefully there is something that someone can do about it.

Link to comment
Share on other sites

  • 3 weeks later...
On 2/22/2022 at 4:48 PM, mrmouse said:

@Leeghoofd
Thank you very much for this ISO; works absolutely great 🙂
Copied ISO-Content on USB-Stick (16GB/Fat32) and Voilà.

Installed a few Times, tested and still testing with:
Ryzen 7 5800X
MSI MAG X570 Tomahawk WIFI (BIOS 7C84v17)
32GB DDR4 (2x16GB) (G.Skill RipJaws V F4-4000C16D-32GVK)
Sapphire Radeon RX 580 & ASUS Geforce 210
Samsung 840 EVO (250GB/SATA)
Keyboard @ PS2 / Mouse @ USB2.0

Best Greetings

Hi, link for x570 iso is dead, can you upload it somewhere please? 😭
Thank you!

Link to comment
Share on other sites

  • 5 weeks later...
On 8/6/2022 at 6:10 PM, Liros said:

Hi, link for x570 iso is dead, can you upload it somewhere please? 😭
Thank you!

Hello together :)

It took a bit, cause i had big trouble to find that ISO on my HDD's-Chaos; i nearly thought, that i lost it.
Found it last Night; maybe.

So there are two different ISOs.
One seems to be updated in some Way. Sadly i can't tell you, which one of these i used.

But i recommend that you also download that 'Windows Updater' which Leeghoofd posted; maybe i have done something with that.
Uploaded the ISOs to a HiDrive; can't guarantee how long they will be up.

https://hidrive.ionos.com/share/g0hn.7zvzk

Maybe you can give a response, if it worked or not. Good Luck and Have Fun.

Best Greetings

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...